DRUPAL-CORE-2021-003

En bref

Publiée
Mise à jour
CVE
CVE-2021-33829
Alias
BIT-drupal-2021-33829, GHSA-rgx6-rjj4-c388

Description

**Update: 2021-06-11: Added CVE-2021-33829 identifier** Drupal core uses the third-party CKEditor library. This library has an error in parsing HTML that could lead to an XSS attack. CKEditor 4.16.1 and later include the fix. Update: 2021-06-11: More details are available on [CKEditor's blog](https://ckeditor.com/blog/ckeditor-4.16.1-with-accessibility-enhancements/#improvements-for-comments-in-html-parser). Users of the CKEditor library via means other than Drupal core should update their 3rd party code (e.g. the WYSIWYG module for Drupal 7). The Drupal Security Team policy is not to alert for issues affecting 3rd party libraries unless those are shipped with Drupal core. See [DRUPAL-SA-PSA-2016-004 for more details](https://www.drupal.org/psa-2016-004). This issue is mitigated by the fact that it only affects sites with CKEditor enabled.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.0.0, fixed 8.9.16 ; introduced 9.0.0, fixed 9.0.14 ; introduced 9.1.0, fixed 9.1.9

Références

Sources

SourceLicence
OSV.devSee osv.dev/data for this database's licence