GHSA-238x-w2j9-gwwr
Payload vulnerable to API key disclosure through ordinary document reads
At a glance
- Published
- Updated
- CVE
- CVE-2026-105849
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
### Impact Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled. You are affected if: - An authentication collection enables `useAPIKey`. - Users have read access to other user documents containing active API keys. ### Patches Users should upgrade payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Disable `useAPIKey` or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.
Affected packages
| Package | Versions |
|---|---|
| npm · payload | introduced 3.0.0, fixed 3.90.0 |
| npm · payload | introduced 4.0.0-canary.0, fixed 4.0.0-canary.34 |
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-238x-w2j9-gwwr WEB
- https://github.com/payloadcms/payload/commit/880d2e900be22cd66a9e939f2b3e702fa413180f WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.90.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |