GHSA-23hv-mwm6-g8jf

Apache Tomcat Session Fixation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2025-55668
Alias
BIT-tomcat-2025-55668
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Description

Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-catalinaintroduced 11.0.0-M1, fixed 11.0.8
Maven · org.apache.tomcat:tomcat-catalinaintroduced 10.1.0-M1, fixed 10.1.42
Maven · org.apache.tomcat:tomcat-catalinaintroduced 9.0.0.M1, fixed 9.0.106
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.8
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.42
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0.M1, fixed 9.0.106

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database