GHSA-2j4q-9fff-236j

Apache Struts XSS Vulnerability

At a glance

Published
Updated
CVE
CVE-2016-2162
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Apache Struts 2.x before 2.3.28 does not sanitize text in the Locale object constructed by I18NInterceptor, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors involving language display.

Affected packages

PackageVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 2.3.28

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database