GHSA-2jrm-gww7-wch2
Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration
At a glance
- Published
- Updated
- CVE
- CVE-2021-20187
- Aliases
- BIT-moodle-2021-20187
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.
Affected packages
| Package | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.5, fixed 3.5.16 |
| Packagist · moodle/moodle | introduced 3.8, fixed 3.8.7 |
| Packagist · moodle/moodle | introduced 3.9, fixed 3.9.4 |
| Packagist · moodle/moodle | introduced 3.10, fixed 3.10.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-20187 ADVISORY
- https://github.com/moodle/moodle PACKAGE
- https://moodle.org/mod/forum/discuss.php?d=417171 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |