GHSA-329j-jfvr-rhr6

Apache Spark vulnerable to Improper Privilege Management

En bref

Publiée
Mise à jour
CVE
CVE-2023-22946
Alias
BIT-spark-2023-22946, PYSEC-2023-44
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Description

In Apache Spark versions prior to versions 3.4.0 and 3.3.3, applications using spark-submit can specify a `proxy-user` to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0, 3.3.3, or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

Paquets affectés

PaquetVersions
Maven · org.apache.spark:spark-core_2.12introduced 0, fixed 3.3.3
Maven · org.apache.spark:spark-core_2.13introduced 0, fixed 3.3.3
PyPI · pysparkintroduced 0, fixed 3.3.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database