GHSA-33c5-9fx5-fvjm
Privilege Escalation in Kubernetes
At a glance
- Published
- Updated
- CVE
- CVE-2020-8559
- Aliases
- GO-2024-2748
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Description
The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.7 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an attacker to escalate privileges from a node compromise to a full cluster compromise.
Affected packages
| Package | Versions |
|---|---|
| Go · k8s.io/apimachinery | introduced 0, fixed 0.16.13 |
| Go · k8s.io/apimachinery | introduced 0.17.0, fixed 0.17.9 |
| Go · k8s.io/apimachinery | introduced 0.18.0, fixed 0.18.7 |
| Go · k8s.io/kubernetes | introduced 0, fixed 1.16.13 |
| Go · k8s.io/kubernetes | introduced 1.17.0, fixed 1.17.9 |
| Go · k8s.io/kubernetes | introduced 1.18.0, fixed 1.18.7 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-8559 ADVISORY
- https://github.com/kubernetes/kubernetes/issues/92914 WEB
- https://github.com/kubernetes/kubernetes/pull/92941 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1851422 WEB
- https://github.com/kubernetes/kubernetes PACKAGE
- https://github.com/tdwyer/CVE-2020-8559 WEB
- https://groups.google.com/d/msg/kubernetes-security-announce/JAIGG5yNROs/19nHQ5wkBwAJ WEB
- https://groups.google.com/g/kubernetes-security-announce/c/JAIGG5yNROs WEB
- https://security.netapp.com/advisory/ntap-20200810-0004 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |