GHSA-3pqx-4fqf-j49f

Deserialization of Untrusted Data in PyYAML

En bref

Publiée
Mise à jour
CVE
CVE-2019-20477
Alias
PYSEC-2020-176
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.

Paquets affectés

PaquetVersions
PyPI · pyyamlintroduced 5.1, fixed 5.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database