GHSA-4wf5-vphf-c2xc
Terser insecure use of regular expressions leads to ReDoS
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-25858
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · terser | introduced 0, fixed 4.8.1 |
| npm · terser | introduced 5.0.0, fixed 5.14.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-25858 ADVISORY
- https://github.com/terser/terser/commit/a4da7349fdc92c05094f41d33d06d8cd4e90e76b WEB
- https://github.com/terser/terser/commit/d8cc5691be980d663c29cc4d5ce67e852d597012 WEB
- https://github.com/terser/terser PACKAGE
- https://github.com/terser/terser/blob/master/lib/compress/evaluate.js%23L135 WEB
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2949722 WEB
- https://snyk.io/vuln/SNYK-JS-TERSER-2806366 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |