GHSA-4wf5-vphf-c2xc

Terser insecure use of regular expressions leads to ReDoS

En bref

Publiée
Mise à jour
CVE
CVE-2022-25858
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

The package terser before 4.8.1, from 5.0.0 and before 5.14.2 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure usage of regular expressions.

Paquets affectés

PaquetVersions
npm · terserintroduced 0, fixed 4.8.1
npm · terserintroduced 5.0.0, fixed 5.14.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database