GHSA-536q-8gxx-m782

Cross-Site Scripting in dojo

En bref

Publiée
Mise à jour
CVE
CVE-2010-2273

Description

Versions of `dojo` prior to 1.4.2 are vulnerable to DOM-based Cross-Site Scripting (XSS). The package does not sanitize URL parameters in the `_testCommon.js` and `runner.html` test files, allowing attackers to execute arbitrary JavaScript in the victim's browser. ## Recommendation Upgrade to version 1.4.2 or later.

Paquets affectés

PaquetVersions
npm · dojointroduced 1.13.0, fixed 1.13.1
npm · dojointroduced 1.12.0, fixed 1.12.4
npm · dojointroduced 1.11.0, fixed 1.11.6
npm · dojointroduced 1.10.0, fixed 1.10.10

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database