GHSA-5mwr-jg3r-jv66
Jenkins allows Cross-Site Scripting (XSS)
At a glance
- Published
- Updated
- CVE
- CVE-2015-5326
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
Description
Cross-site scripting (XSS) vulnerability in the slave overview page in Jenkins before 1.638 and LTS before 1.625.2 allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via the slave offline status message.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.625.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.626, fixed 1.638 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5326 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/abe561499bbba2e725804c1117fc957028bbd608 WEB
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11 WEB
- http://rhn.redhat.com/errata/RHSA-2016-0489.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |