GHSA-5rrg-rr89-x9mv
Ansible Exposes Sensitive Information
At a glance
- Published
- Updated
- CVE
- CVE-2021-20228
- Aliases
- PYSEC-2021-1
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
A flaw was found in the Ansible Engine prior to 2.10.6rc1, 2.9.18rc1, and 2.8.19rc1, where sensitive info is not masked by default and is not protected by the `no_log` feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.
Affected packages
| Package | Versions |
|---|---|
| PyPI · ansible | introduced 2.10.0a1, fixed 2.10.6rc1 |
| PyPI · ansible | introduced 2.9.0a1, fixed 2.9.18rc1 |
| PyPI · ansible | introduced 0, fixed 2.8.19rc1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-20228 ADVISORY
- https://github.com/ansible/ansible/pull/73487 WEB
- https://github.com/ansible/ansible/pull/73492 WEB
- https://github.com/ansible/ansible/pull/73493 WEB
- https://github.com/ansible/ansible/pull/73494 WEB
- https://github.com/ansible/ansible/commit/49ebd509df9de1c1fc1bcee00e79a835dd00662c WEB
- https://github.com/ansible/ansible/commit/e41d1f0a3fd6c466192e7e24accd3d1c6501111b WEB
- https://github.com/ansible/ansible/commit/f8ff395d817c3eddc050f809919c15dfb5796120 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1925002 WEB
- https://github.com/advisories/GHSA-5rrg-rr89-x9mv ADVISORY
- https://github.com/ansible/ansible PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-1.yaml WEB
- https://www.debian.org/security/2021/dsa-4950 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |