GHSA-5v5p-x8c2-mqxp

Magento 2 Community Edition RCE Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2019-8122
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with privileges to create products can craft custom layout update and use import product functionality to enable remote code execution.

Paquets affectés

PaquetVersions
Packagist · magento/community-editionintroduced 2.1.0, fixed 2.1.19
Packagist · magento/community-editionintroduced 2.2.0, fixed 2.2.10
Packagist · magento/community-editionintroduced 2.3.0, fixed 2.3.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database