GHSA-69p3-xp37-f692
Improper Certificate Validation in kubeclient
At a glance
- Published
- Updated
- CVE
- CVE-2022-0759
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
A flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).
Affected packages
| Package | Versions |
|---|---|
| RubyGems · kubeclient | introduced 0, fixed 4.9.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0759 ADVISORY
- https://github.com/ManageIQ/kubeclient/issues/554 WEB
- https://github.com/ManageIQ/kubeclient/issues/555 WEB
- https://github.com/ManageIQ/kubeclient/pull/556 WEB
- https://github.com/ManageIQ/kubeclient/commit/109ea71de5a8881748f03ebbe103b49f0f1c7887 WEB
- https://github.com/ManageIQ/kubeclient PACKAGE
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/kubeclient/CVE-2022-0759.yml WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |