GHSA-6mv9-hcx5-7mhh
Server-Side Request Forgery in Jenkins
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-1000067
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Description
An improper authorization vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker to have Jenkins submit HTTP GET requests and get limited information about the response.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.89.4 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.90, fixed 2.107 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000067 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/2d16b459205730d85e51499c2457109b234ca9d9 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2018-02-14/#SECURITY-506 WEB
- https://www.oracle.com/security-alerts/cpuapr2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |