GHSA-6wvf-77m9-58rm

LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint

At a glance

Published
Updated
CVE
CVE-2026-37004
Aliases
PYSEC-2026-3861
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

BerriAI litellm <=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute arbitrary OS commands via a crafted dotprompt_content parameter in the /prompts/test endpoint due to use of an unsandboxed jinja2.Environment.

Affected packages

PackageVersions
PyPI · litellmintroduced 0, fixed 1.83.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database