GHSA-6wvf-77m9-58rm
LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint
At a glance
- Published
- Updated
- CVE
- CVE-2026-37004
- Aliases
- PYSEC-2026-3861
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
BerriAI litellm <=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute arbitrary OS commands via a crafted dotprompt_content parameter in the /prompts/test endpoint due to use of an unsandboxed jinja2.Environment.
Affected packages
| Package | Versions |
|---|---|
| PyPI · litellm | introduced 0, fixed 1.83.7 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-37004 ADVISORY
- https://github.com/BerriAI/litellm/commit/d910a95661fce3cdd36f3b06c03ecf9c46c6457c WEB
- https://github.com/BerriAI/litellm PACKAGE
- https://github.com/BerriAI/litellm/blob/244bdffd1bfe7bebdfdef516e1ebe426a898e2f0/litellm/proxy/prompts/prompt_endpoints.py#L1073 WEB
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable WEB
- https://yerangamage.com/cves/detail/?slug=litellm-ssti-rce WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |