GHSA-74vq-h4q8-x6jv
Ansible Path Traversal vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2019-3828
- Aliases
- PYSEC-2019-5
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
Description
Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.
Affected packages
| Package | Versions |
|---|---|
| PyPI · ansible | introduced 0, fixed 2.5.15 |
| PyPI · ansible | introduced 2.6.0a1, fixed 2.6.14 |
| PyPI · ansible | introduced 2.7.0a1, fixed 2.7.8 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-3828 ADVISORY
- https://github.com/ansible/ansible/pull/52133 WEB
- https://github.com/ansible/ansible/commit/396a2f74717477d80600450e2b7e45349d7b5110 WEB
- https://github.com/ansible/ansible/commit/4be3215d2f9f84ca283895879f0c6ce1ed7dd333 WEB
- https://github.com/ansible/ansible/commit/f3edc091523fbe301926b7a0db25fbbd96940d93 WEB
- https://access.redhat.com/errata/RHSA-2019:3744 WEB
- https://access.redhat.com/errata/RHSA-2019:3789 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3828 WEB
- https://github.com/advisories/GHSA-74vq-h4q8-x6jv ADVISORY
- https://github.com/ansible/ansible PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-5.yaml WEB
- https://usn.ubuntu.com/4072-1 WEB
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html WEB
- http://packetstormsecurity.com/files/172837/Ansible-Fetch-Path-Traversal.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |