GHSA-78wr-2p64-hpwj
Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-47554
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
Uncontrolled Resource Consumption vulnerability in Apache Commons IO. The `org.apache.commons.io.input.XmlStreamReader` class may excessively consume CPU resources when processing maliciously crafted input. This issue affects Apache Commons IO: from 2.0 before 2.14.0. Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · commons-io:commons-io | introduced 2.0, fixed 2.14.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-47554 ADVISORY
- https://github.com/apache/commons-io PACKAGE
- https://lists.apache.org/thread/6ozr91rr9cj5lm0zyhv30bsp317hk5z1 WEB
- https://security.netapp.com/advisory/ntap-20250131-0010 WEB
- http://www.openwall.com/lists/oss-security/2024/10/03/2 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |