GHSA-8g4f-fh7f-4fwh

Apache Tomcat Default Installation Reveals Sensitive Information

At a glance

Published
Updated
CVE
CVE-2002-2006

Description

The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows remote attackers to obtain the installation path and other sensitive system information via the (1) SnoopServlet or (2) TroubleShooter example servlets.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 4.0.0, fixed 4.1.0
Maven · org.apache.tomcat:tomcatintroduced 3.0, fixed 3.3a

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database