GHSA-8m9x-pxwq-j236
Pillow command injection
At a glance
- Published
- Updated
- CVE
- CVE-2014-3007
- Aliases
- PYSEC-2014-87
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
Python Image Library (PIL) 1.1.7 and earlier and Pillow before 2.5.0 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.
Affected packages
| Package | Versions |
|---|---|
| PyPI · pillow | introduced 0, fixed 2.5.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3007 ADVISORY
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=737059 WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2014-87.yaml WEB
- https://github.com/python-pillow/Pillow PACKAGE
- http://people.canonical.com/~ubuntu-security/cve/2014/CVE-2014-1932.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |