GHSA-92cc-952p-v8rh

Apache Hadoop HDFS Native Client has Out-of-bounds Write Vulnerability

At a glance

Published
Updated
CVE
CVE-2025-27821
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client. This issue affects Apache Hadoop: from 3.2.0 before 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.hadoop:hadoop-hdfs-native-clientintroduced 3.2.0, fixed 3.4.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database