GHSA-98vv-pw6r-q6q4

Uncontrolled Resource Consumption in pillow

At a glance

Published
Updated
CVE
CVE-2021-23437
Aliases
BIT-pillow-2021-23437, PYSEC-2021-317, SNYK-PYTHON-PILLOW-1319443
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

Affected packages

PackageVersions
PyPI · pillowintroduced 5.2.0, fixed 8.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database