GHSA-9v8h-qqgm-4m35

Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

At a glance

Published
Updated
CVE
CVE-2026-111497
Aliases
BIT-node-2026-111497, BIT-node-min-2026-111497, PYSEC-2026-4322, PYSEC-2026-4323
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Affected packages

PackageVersions
PyPI · brotliintroduced 1.0.3, fixed 1.2.1
PyPI · brotlicffiintroduced 1.0.3, fixed 1.2.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database