GHSA-9w38-p64v-xpmv

Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree

En bref

Publiée
Mise à jour
CVE
CVE-2024-29133
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Description

This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' calling 'ListDelimiterHandler.flatten(Object, int)' with a cyclical object tree. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.commons:commons-configuration2introduced 2.0, fixed 2.10.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database