GHSA-c38m-9668-6j2w
Magento Improper input validation vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2021-28585
- Aliases
- BIT-magento-2021-28585
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation vulnerability in the New customer WebAPI.Successful exploitation could allow an attacker to send unsolicited spam e-mails.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 2.4.0, fixed 2.4.2-p1 |
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7 |
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-28585 ADVISORY
- https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695 WEB
- https://helpx.adobe.com/security/products/magento/apsb21-30.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |