GHSA-c7qv-q95q-8v27

Denial of service in http-proxy-middleware

At a glance

Published
Updated
CVE
CVE-2024-21536
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Versions of the package http-proxy-middleware before 2.0.7, from 3.0.0 and before 3.0.3 are vulnerable to Denial of Service (DoS) due to an UnhandledPromiseRejection error thrown by micromatch. An attacker could kill the Node.js process and crash the server by making requests to certain paths.

Affected packages

PackageVersions
npm · http-proxy-middlewareintroduced 0, fixed 2.0.7
npm · http-proxy-middlewareintroduced 3.0.0, fixed 3.0.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database