GHSA-cchx-mfrc-fwqr

Improper authentication in Symfony

En bref

Publiée
Mise à jour
CVE
CVE-2019-10911
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.

Paquets affectés

PaquetVersions
Packagist · symfony/security-httpintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/security-httpintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/security-httpintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/security-httpintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/security-httpintroduced 4.2.0, fixed 4.2.7
Packagist · symfony/securityintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/securityintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/securityintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/securityintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/securityintroduced 4.2.0, fixed 4.2.7
Packagist · symfony/symfonyintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/symfonyintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/symfonyintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/symfonyintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/symfonyintroduced 4.2.0, fixed 4.2.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database