GHSA-cgvx-9447-vcch

ntlk unsafe deserialization vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2024-39705
Alias
PYSEC-2024-167
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.

Paquets affectés

PaquetVersions
PyPI · nltkintroduced 0, fixed 3.9

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database