GHSA-cp7v-vmv7-6x2q

Incorrect Authorization in Undertow

En bref

Publiée
Mise à jour
CVE
CVE-2017-12196
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Undertow before versions 1.4.18.SP1 (not findable in Maven), 2.0.2.Final, and 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.

Paquets affectés

PaquetVersions
Maven · io.undertow:undertow-coreintroduced 2.0.0.Alpha1, fixed 2.0.2.FInal
Maven · io.undertow:undertow-coreintroduced 0, fixed 1.4.24.Final

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database