GHSA-fccv-jmmp-qg76

Apache Tomcat Improper Input Validation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-46589
Alias
BIT-tomcat-2023-46589
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:tomcat-catalinaintroduced 11.0.0-M1, fixed 11.0.0-M11
Maven · org.apache.tomcat:tomcat-catalinaintroduced 10.1.0-M1, fixed 10.1.16
Maven · org.apache.tomcat:tomcat-catalinaintroduced 9.0.0-M1, fixed 9.0.83
Maven · org.apache.tomcat:tomcat-catalinaintroduced 8.5.0, fixed 8.5.96
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.0-M11
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.16
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.0-M1, fixed 9.0.83
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.0, fixed 8.5.96
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.0-M1, fixed 11.0.0-M11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database