GHSA-fh64-r2vc-xvhr

MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface

At a glance

Published
Updated
CVE
CVE-2026-33865
Aliases
BIT-mlflow-2026-33865, PYSEC-2026-93
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N

Description

MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file containing a payload that executes when another user views the artifact in the UI. This allows actions such as session hijacking or performing operations on behalf of the victim. This issue affects MLflow version through 3.10.1

Affected packages

PackageVersions
PyPI · mlflowintroduced 0, fixed 3.11.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database