GHSA-fq9f-9wv9-rfmg

Improper Certificate Validation in Jenkins

At a glance

Published
Updated
CVE
CVE-2017-1000396
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins plugins. The fix for CVE-2012-6153 was backported to the version of commons-httpclient that is bundled in core and made available to plugins.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.73.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.74, fixed 2.84

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database