GHSA-fwqr-3pvp-pjwq

Deserialization of Untrusted Data in Jenkins

At a glance

Published
Updated
CVE
CVE-2017-2608
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.32.2
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.34, fixed 2.44

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database