GHSA-fwqr-3pvp-pjwq
Deserialization of Untrusted Data in Jenkins
At a glance
- Published
- Updated
- CVE
- CVE-2017-2608
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Jenkins before versions 2.44, 2.32.2 is vulnerable to a remote code execution vulnerability involving the deserialization of various types in javax.imageio in XStream-based APIs (SECURITY-383).
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.32.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.34, fixed 2.44 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-2608 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2608 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2017-02-01 WEB
- http://www.securityfocus.com/bid/95953 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |