GHSA-grgm-pph5-j5h7

Exposure of Sensitive Information to an Unauthorized Actor in ansible

En bref

Publiée
Mise à jour
CVE
CVE-2019-10156
Alias
PYSEC-2019-2
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.6.18
PyPI · ansibleintroduced 2.7.0a1, fixed 2.7.12
PyPI · ansibleintroduced 2.8.0a1, fixed 2.8.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database