GHSA-gx6r-qc2v-3p3v

systeminformation SSID Command Injection Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2023-42810
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

### Impact SSID Command Injection Vulnerability ### Patches Problem was fixed with a parameter check. Please upgrade to version >= 5.21.7, Version 4 was not affected ### Workarounds If you cannot upgrade, be sure to check or sanitize parameter strings that are passed to wifiConnections(), wifiNetworks() (string only) ### References See also https://systeminformation.io/security.html

Paquets affectés

PaquetVersions
npm · systeminformationintroduced 5.0.0, fixed 5.21.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database