GHSA-hp5w-3hxx-vmwf

Payload: Pre-Authentication Account Takeover via Parameter Injection in Password Recovery

At a glance

Published
Updated
CVE
CVE-2026-34751
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Description

### Impact A vulnerability in the password recovery flow could allow an unauthenticated attacker to perform actions on behalf of a user who initiates a password reset. Users are affected if: - They are using Payload version **< v3.79.1** with any auth-enabled collection using the built-in `forgot-password` functionality. ### Patches Input validation and URL construction in the password recovery flow have been hardened. Users should upgrade to **v3.79.1** or later. ### Workarounds There are no complete workarounds. Upgrading to **v3.79.1** is recommended.

Affected packages

PackageVersions
npm · payloadintroduced 0, fixed 3.79.1
npm · @payloadcms/graphqlintroduced 0, fixed 3.79.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database