GHSA-hpx4-r86g-5jrg
@adobe/css-tools Regular Expression Denial of Service (ReDOS) while Parsing CSS
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-26364
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
Description
### Impact @adobe/css-tools version 4.3.0 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS. ### Patches The issue has been resolved in 4.3.1. ### Workarounds None ### References N/A
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · @adobe/css-tools | introduced 0, fixed 4.3.1 |
Références
- https://github.com/adobe/css-tools/security/advisories/GHSA-hpx4-r86g-5jrg WEB
- https://nvd.nist.gov/vuln/detail/CVE-2023-26364 ADVISORY
- https://github.com/adobe/css-tools/commit/2b09a25d1dbdbb16fe80065e4c9beb5623ee5793 WEB
- https://github.com/adobe/css-tools PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |