GHSA-jgpr-qrw2-6gp3

Exposure of Sensitive Information in Jenkins Core

At a glance

Published
Updated
CVE
CVE-2016-0790
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

Jenkins before 1.650 and LTS before 1.642.2 do not use a constant-time algorithm to verify API tokens, which makes it easier for remote attackers to determine API tokens via a brute-force approach.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 1.650

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database