GHSA-jmgw-6vjg-jjwg

actionpack Improper Input Validation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2013-0156

Description

`active_support/core_ext/hash/conversions.rb` in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion.

Paquets affectés

PaquetVersions
RubyGems · actionpackintroduced 0, fixed 2.3.15
RubyGems · actionpackintroduced 3.0.0, fixed 3.0.19
RubyGems · actionpackintroduced 3.1.0, fixed 3.1.10
RubyGems · actionpackintroduced 3.2.0, fixed 3.2.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database