GHSA-m7r6-43v2-49vf

Mongrel vulnerable to directory traversal via double-encoded sequences

At a glance

Published
Updated
CVE
CVE-2007-6612

Description

Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 (1.0.3 and prior are not affected) and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (`.%252e`).

Affected packages

PackageVersions
RubyGems · mongrelintroduced 1.0.4, fixed 1.0.5
RubyGems · mongrelintroduced 1.1.0, fixed 1.1.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database