GHSA-mcmc-2m55-j8jj
vLLM introduced enhanced protection for CVE-2025-62164
At a glance
- Published
- Updated
- CVE
- CVE-2026-56340
- Aliases
- PYSEC-2026-250
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
### Summary The fix [here](https://github.com/vllm-project/vllm/pull/27204) for CVE-2025-62164 is not sufficient. The fix only disables prompt embeds by default rather than addressing the root cause, so the DoS vulnerability remains when the feature is enabled. ### Details vLLM's pending change attempts to fix the root cause, which is the missing sparse tensor validation. PyTorch (~v2.0) disables sparse tensor validation (specifically, sparse tensor invariants checks) by default for performance reasons. vLLM is adding the sparse tensor validation to ensure indices are valid, non-negative, and within bounds. These checks help catch malformed tensors. ### PoC NA ### Impact Current fix only added a flag to disable/enable prompt embeds, so by default, prompt embeds feature is disabled in vLLM, which stops DoS attacks through the embeddings. However, It doesn’t address the problem when the flag is enabled and there is still potential for DoS attacks. ### Changes * https://github.com/vllm-project/vllm/pull/30649
Affected packages
| Package | Versions |
|---|---|
| PyPI · vllm | introduced 0.10.2, fixed 0.13.0 |
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-mcmc-2m55-j8jj WEB
- https://github.com/vllm-project/vllm/pull/30649 WEB
- https://access.redhat.com/security/cve/CVE-2026-56340 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=2491060 WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-250.yaml WEB
- https://github.com/vllm-project/vllm PACKAGE
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json WEB
- https://www.vulncheck.com/advisories/vllm-denial-of-service-via-unvalidated-multimodal-embeddings WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |