GHSA-mqvr-2rp8-j7h4
Spring LDAP data exposure vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-38829
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Description
A vulnerability in Spring LDAP allows data exposure for case sensitive comparisons.This issue affects Spring LDAP: from 2.4.0 through 2.4.3, from 3.0.0 through 3.0.9, from 3.1.0 through 3.1.7, from 3.2.0 through 3.2.7, AND all versions prior to 2.4.0. The usage of String.toLowerCase() and String.toUpperCase() has some Locale dependent exceptions that could potentially result in unintended columns from being queried Related to CVE-2024-38820 https://spring.io/security/cve-2024-38820
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.springframework.ldap:spring-ldap-core | introduced 3.0.0, fixed 3.2.8 |
| Maven · org.springframework.ldap:spring-ldap-core | introduced 0, fixed 2.4.4 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-38829 ADVISORY
- https://github.com/spring-projects/spring-ldap PACKAGE
- https://spring.io/security/cve-2024-38829 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |