GHSA-mvfq-ggxm-9mc5
Django vulnerable to ASGI header spoofing via underscore/hyphen conflation
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-3902
- Alias
- BIT-django-2026-3902, PYSEC-2026-51
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. `ASGIRequest` allows a remote attacker to spoof headers by exploiting an ambiguous mapping of two header variants (with hyphens or with underscores) to a single version with underscores. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Tarek Nakkouch for reporting this issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · django | introduced 6.0, fixed 6.0.4 |
| PyPI · django | introduced 5.2, fixed 5.2.13 |
| PyPI · django | introduced 4.2, fixed 4.2.30 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-3902 ADVISORY
- https://docs.djangoproject.com/en/dev/releases/security WEB
- https://github.com/django/django PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-51.yaml WEB
- https://groups.google.com/g/django-announce WEB
- https://www.djangoproject.com/weblog/2026/apr/07/security-releases WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |