GHSA-mvjj-gqq2-p4hw
Cross-Site Scripting in react-dom
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-6341
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
Affected versions of `react-dom` are vulnerable to Cross-Site Scripting (XSS). The package fails to validate attribute names in HTML tags which may lead to Cross-Site Scripting in specific scenarios. This may allow attackers to execute arbitrary JavaScript in the victim's browser. To be affected by this vulnerability, the application needs to: - be a server-side React app - be rendered to HTML using `ReactDOMServer` - include an attribute name from user input in an HTML tag ## Recommendation If you are using `react-dom` 16.0.x, upgrade to 16.0.1 or later. If you are using `react-dom` 16.1.x, upgrade to 16.1.2 or later. If you are using `react-dom` 16.2.x, upgrade to 16.2.1 or later. If you are using `react-dom` 16.3.x, upgrade to 16.3.3 or later. If you are using `react-dom` 16.4.x, upgrade to 16.4.2 or later.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · react-dom | introduced 16.0.0, fixed 16.0.1 |
| npm · react-dom | introduced 16.1.0, fixed 16.1.2 |
| npm · react-dom | introduced 16.2.0, fixed 16.2.1 |
| npm · react-dom | introduced 16.3.0, fixed 16.3.3 |
| npm · react-dom | introduced 16.4.0, fixed 16.4.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-6341 ADVISORY
- https://github.com/advisories/GHSA-mvjj-gqq2-p4hw ADVISORY
- https://reactjs.org/blog/2018/08/01/react-v-16-4-2.html WEB
- https://snyk.io/vuln/npm:react-dom:20180802 WEB
- https://twitter.com/reactjs/status/1024745321987887104 WEB
- https://www.npmjs.com/advisories/1421 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |