GHSA-p64j-r5f4-pwwx

Improper Validation of Array Index in GJSON

At a glance

Published
Updated
CVE
CVE-2020-36067
Aliases
GO-2021-0054
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

GJSON < 1.6.6 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.

Affected packages

PackageVersions
Go · github.com/tidwall/gjsonintroduced 0, fixed 1.6.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database