GHSA-p6xc-xr62-6r2g

Apache Log4j2 vulnerable to Improper Input Validation and Uncontrolled Recursion

En bref

Publiée
Mise à jour
CVE
CVE-2021-45105
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

Description

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0 and 2.12.3. # Affected packages Only the `org.apache.logging.log4j:log4j-core` package is directly affected by this vulnerability. The `org.apache.logging.log4j:log4j-api` should be kept at the same version as the `org.apache.logging.log4j:log4j-core` package to ensure compatability if in use.

Paquets affectés

PaquetVersions
Maven · org.apache.logging.log4j:log4j-coreintroduced 2.4.0, fixed 2.12.3
Maven · org.apache.logging.log4j:log4j-coreintroduced 2.13.0, fixed 2.17.0
Maven · org.apache.logging.log4j:log4j-coreintroduced 0, fixed 2.3.1
Maven · org.ops4j.pax.logging:pax-logging-log4j2introduced 1.8.0, fixed 1.9.2
Maven · org.ops4j.pax.logging:pax-logging-log4j2introduced 1.10.0, fixed 1.10.9
Maven · org.ops4j.pax.logging:pax-logging-log4j2introduced 1.11.0, fixed 1.11.12
Maven · org.ops4j.pax.logging:pax-logging-log4j2introduced 2.0.0, fixed 2.0.13

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database