GHSA-p92q-7fhh-mq35

Cross-Site Request Forgery in Jenkins

En bref

Publiée
Mise à jour
CVE
CVE-2022-20612
Alias
BIT-jenkins-2022-20612
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Description

Jenkins 2.329 and earlier, LTS 2.319.1 and earlier does not require POST requests for the HTTP endpoint handling manual build requests when no security realm is set, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to trigger build of job without parameters. Jenkins 2.330, LTS 2.319.2 requires POST requests for the affected HTTP endpoint.

Paquets affectés

PaquetVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.320, fixed 2.330
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.319.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database